A fix has been implemented, and we are monitoring the results. All services should be operational now.
Posted Sep 08, 2025 - 17:45 UTC
Identified
We are currently experiencing a database issue that has caused some services to be unavailable. We are aware of the issue and are currently implementing a fix.
Posted Sep 08, 2025 - 17:18 UTC
This incident affected: Portal, Claims, Verification Services, Partner API, and PMS Integrations.